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Chapter 1:
Using this Manual

Manual Overview (pg. 2)

Conventions (pg. 3)

Special Messages (pg. 3)

Note (pg. 3)

Important (pg. 3)

Caution (pg. 3)

Warning (pg. 4)

Troubleshooting (pg. 4)

Specialized Text (pg. 4)

This chapter provides an overview of this manual’s organization and the conventions used throughout.

NOTE: Images used throughout this manual are for illustrative purposes only.
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Chapter 1: Using this Manual

Manual Overview 
This manual provides information to support you during installation and setup of the USB-Link™ 3 
Wireless Edition and Wired Edition.

This manual is composed of the following sections:

• Chapter 1: Using this Manual—provides an overview of this user manual.

•  Chapter 2: Introducing the USB-Link™ 3 Wireless Edition and Wired Edition—provides details on 
communication options, including Bluetooth®, Wi-Fi, USB, Mini Access Mode, and Infrastructure Mode.

•  Chapter 3: Installing the Drivers and Setting up the Device—provides instructions for installing NEXIQTM 

drivers and utilities, connecting to a vehicle, pairing the device, and testing the connection. It also 
provides information on using the USB-Link™ 3 Explorer.
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Conventions 
This section provides descriptions of the conventions used throughout this guide.

Special Messages
Note

NOTE provides an explanation, comment, or tip related to the subject matter that is being discussed.

Example:

Important

IMPORTANT indicates a situation which may damage the test equipment or vehicle.

Example:

Caution

CAUTION indicates a potentially hazardous situation which may result in minor or moderate injury to the 
operator or bystanders.

Example:

NOTE: Refer to the page number indicated for further details on the described component.

IMPORTANT: Keep all cables clear of moving or hot engine parts.

CAUTION: Do not use the unit to perform tests on household or industrial sources.
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Warning

WARNING indicates a potentially hazardous situation which could result in serious injury or death to 
the operator or bystanders.

Example:

Troubleshooting

Information intended to help you to address or anticipate potential issues are presented in the 
following manner:

Specialized Text
The specially formatted text is used to help you to differentiate specific elements discussed within  
this manual:

• Emphasis: Used to draw your attention to particularly important information.

•  FEATURE: Used to highlight the name of a specific feature.  
Example: “Click on the Finish button to continue.”

•  Field/Line: Used to highlight the name of a field or a line of text from a display. 
Example: “A check mark is placed in the check box next to the Total Fuel Used parameter.”

•  Menu Items: Used to highlight a series of menu selections. 
Example: “From the Start menu, select Programs > NEXIQ > Device Tester.”

•  Screen titles: Used to highlight the title of a screen displayed.  
Example: “The Installation Complete screen is displayed.”

WARNING: All RP1210 adapters must be disconnected before proceeding with installation.

If NEXIQ WVL2 drivers are installed, the WVL2 Explorer Utility must be exited before proceeding  
with installation.
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Chapter 2:
Introducing the USB-Link™ 3

Component Checklist (pg. 6)

Product Specifications (pg. 7)

System Requirements (pg. 8)

Device Features (pg. 9)

Communication Options: Wired vs Wireless (pg. 12)

Wired USB Connection (pg. 12)

Wireless Bluetooth® Connection (pg. 13)

Wireless Wi-Fi Connection (pg. 14)

Mini Access Point Mode (Peer-to-Peer) (pg. 15)

Infrastructure Mode (Connecting to your Company’s Network) (pg. 16)

The USB-Link™ 3 is a hardware device that enables service bay technicians to use personal computers 
or laptops to retrieve vehicle information using wireless Bluetooth® and Wi-Fi technologies, or a USB 
cable connection. Once configured, the USB-Link™ 3 interfaces with specific PC applications to perform 
vehicle diagnostics.

This chapter introduces the USB-Link™ 3 and provides details regarding the communication modes 
available to interface with your PC. It also introduces the features of the USB-Link™ 3 (i.e., LEDs, 
Pairing Button, USB port, Vehicle port).
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Chapter 2: Introducing the USB-Link™ 3

Component Checklist 
The following components are included with your USB-Link™ 3. Confirm you have all of these items 
before using the device:

• USB-Link™ 3

• Latching USB Cable (see Figure 2.2)

• 9-pin Deutsch Adapter, 1 Meter

• 16-pin, J1962 OBD II Adapter, 1 Meter

• Carrying Case

• USB-Link™ 3 Quick Start Guide

6

NOTE: USB-Link™ 3 drivers and this manual are available for download at the NEXIQ website:  
http://nexiq.com/home/drivers
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Chapter 2: Introducing the USB-Link™ 3

Product Specifications 
The USB-Link™ 3 is configured with the following specifications:

Feature

Physical Dimensions

Weight

Power Requirements

Operating Temperature

API Driver

Vehicle Protocols Supported

USB Communication

USB Connector

Wired Communication

Wireless Communication
Wireless Edition only

Vehicle Connector

Data

6.75” x 3.75” x 1.06”
(171 mm x 95 mm x 27 mm)

8 oz. (0.22 kg)

6 - 32 VDC @ 350 mA maximum

0 to +50 °C

TMC RP1210A, RP1210B, and RP1210C compliant

•  CAN FD / J1939 FD / ISO15765 FD - 250K, 500K,  
1M b/s with auto baud detection

• Single-wire CAN (SWCAN)
• ISO 11898-3 Fault Tolerant CAN (FTCAN)
• DOIP
• J1708
• J1850 VPW (Class 2)
• ISO PWM (SCP)
• ISO 9141 / KWP2000 (ISO 14230) K/L Line
• ALDL 9600 and 8192 baud
• ATEC 160 baud

USB version 2.0

Latching USB Mini-B

Automotive A to Mini-B USB cable 13 ft. (4 m) maximum

• Bluetooth® Class 1 adapter (up to 50 ft range)
• Dual band Wi-Fi (802.11 AC)

High Density D-sub 26-pin Male (HD26M)
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Chapter 2: Introducing the USB-Link™ 3

System Requirements 
Confirm your PC meets the following system requirements:
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Component

IBM PC-compatible computer 
 
 

Operating system

 
Wi-Fi wireless network

Bluetooth®

Requirement

• 1GHz processor or more
• RAM: 256MB or more (512MB recommended)
• USB port, version 2.0 or higher
• Wi-Fi and/or Bluetooth

• Windows® 10
• Windows® 11

• Wi-Fi (802.11a, b, g, n, or AC)

• Bluetooth 2.1 or higher
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Chapter 2: Introducing the USB-Link™ 3

Device Features 
The images below detail the features of the USB-Link™ 3 Wireless Edition and Wired Edition.

Legend

Figure 2.1 USB-Link™ 3 Wireless and Wired Edition

A – Vehicle Port
B – Power LED
C – Vehicle Data LED
D – Fault LED

E – Wireless Comm LED
F – Pairing Button
G – USB Port
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Chapter 2: Introducing the USB-Link™ 3

Device Features 
These features perform the same whether in Bluetooth® or Wi-Fi mode:

The Wireless LED and the Pairing Button perform differently depending on which mode (i.e., Bluetooth®  
or Wi-Fi) the device is in.
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Feature

Vehicle Port 

Power LED

Vehicle Data LED 

Fault LED

USB Port

Feature

Wireless Comm LED: 
Bluetooth® Mode 
 
 
 

Wireless Comm LED:  
Wi-Fi—Mini Access Point Mode

What It Does

Connects the USB-Link™ 3 to a vehicle/engine for  
power and data.

Illuminates when the device receives power.

Illuminates when the device is receiving data from  
the vehicle.

Illuminates when a problem is detected.

Connects the device to your PC (wired connection).
Latching USB Mini-B Connector for connection to PC host. 
Not used with iOS device.

What It Does

If the device is Discoverable:
• Illuminates solid blue when connected.
• Blinks every second when not connected. 

If the device is Non-Discoverable:
• Illuminates solid blue when connected. 
• Off when not connected.

Mini Access Point Mode:
•  Illuminates solid white when a client PC connects to  

the device.
• Off when no client PC is connected.
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Chapter 2: Introducing the USB-Link™ 3

Device Features

11

Feature

Wireless Comm LED:  
Wi-Fi—Infrastructure Mode 
 
 
 
 

Pairing Button 
Bluetooth Mode 
 
 
 
 
 
 
 
 
 
 

Pairing Button 
Wi-Fi Mode

What It Does

Infrastructure Mode:
•  Stays off when not associated with a network  

Access Point.
•  Blinks every second when associated with an access 

point, but no IP address assigned.
•  Illuminates solid orange when successfully assigned  

an IP address.

The Pairing Button is used to change the status of the 
device. The two status modes are:
•  Non-Discoverable—When the USB-Link™ 3 is  

Non-Discoverable, it will only connect to a host device 
with which it has previously been paired.

•  Discoverable—When the USB-Link™ 3 is Discoverable,  
a host device can detect, pair, or connect to it.

To change the mode from Non-Discoverable to 
Discoverable, press and hold the Pairing button until the 
Wireless LED begins to flash blue (about 3 seconds).

Once a connection is established, the LED turns solid 
blue. After two minutes, discover-ability will time out, and 
the device will go back to Non-Discoverable status.

When using Wi-Fi, the USB-Link™ 3 can be configured  
for either of the following modes:
• Mini-Access Point (Wi-Fi default)
• Infrastructure

Note: USB-Link™ 3 cannot be used in Infrastructure 
mode until it has been configured using the Explorer  
utility (see Using the USB-Link™ 3 Explorer in Chapter 3 
of this manual).
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Chapter 2: Introducing the USB-Link™ 3

Communication Options: Wired vs Wireless 
Prior to using the USB-Link™ 3, choose how you want the unit to communicate with your PC.  
There are three options:

• Wired, USB Connection (pg. 12)

• Wireless, Bluetooth® Connection (pg. 13)

• Wireless, Wi-Fi Connection (pg. 14)

Wired USB Connection 
A wired USB connection provides the advantages of high data throughput, low latency, and a  
high-reliability data connection.

Wired communication between the USB-Link™ 3 and your PC requires an automotive A to Mini-B USB 
cable (shipped with the USB-Link™ 3).
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NOTE: For detailed instructions on making a wired connection, refer to Making a Wired USB Connection 
in Chapter 3 of this manual.

IMPORTANT: Electronic Control Module (ECU) reprogramming requires both high throughput and critical 
timing, and should always use a USB-to-PC wired connection.

Figure 2.2 Automotive A to Mini-B USB Cable
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Chapter 2: Introducing the USB-Link™ 3

Wireless Bluetooth Connection
The USB-Link™ 3 can be configured to use Bluetooth® wireless technology to provide communication 
between the USB-Link™ 3 and your PC. When two Bluetooth® devices are paired, a persistent link 
is created between the two devices. Once configured, future connections between the devices are 
authenticated automatically.

13

NOTE: For detailed instructions on configuring the USB-Link™ 3 for Bluetooth®, refer to Making a 
Bluetooth Wireless Connection, in Chapter 3 of this manual.
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Chapter 2: Introducing the USB-Link™ 3

Wireless Wi-Fi Connection
The USB-Link™ 3 can be configured to use Wi-Fi to provide wireless communication between the  
USB-Link™ 3 and your PC.

There are two network options:

• Mini Access Point Mode (pg. 15)

• Infrastructure Mode (pg. 16)

If you use your PC’s internal wireless network card to connect to both your company’s network and the 
USB-Link™ 3, you will not have access to the Internet until you have finished your session. If you prefer 
to have access to the Internet while using performing diagnostics, you will need an additional wireless 
network card dedicated for use with the USB-Link™ 3.

Wi-Fi performance can be affected by network congestion, radio frequency interference, and too many 
wireless devices in the vicinity. These conditions may result in dropped messages. For this reason, 
wireless communication is not recommended for ECU reprogramming (i.e, reflashing).
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Mini Access Point Mode (Peer-to-Peer)
The easiest and quickest way to connect your USB-Link™ 3 to your PC is with the Mini Access Point 
mode. In Mini Access Point mode (also known as Access Point Emulation mode), the PC communicates 
directly with the device. The USB-Link™ 3 emulates the function of an access point, allowing the PC to 
connect directly to the USB-Link™ 3. When the PC is connected to the USB-Link™ 3 in Mini Access Point 
mode, neither device is connected to the company network.

If you use your PC’s internal wireless network card to connect to both your company’s network and the 
USB-Link™ 3, you will not have access to the Internet until you have finished your session. If you prefer 
to have access to the Internet while using performing diagnostics, you will need an additional wireless 
network card dedicated for use with the USB-Link™ 3.
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Figure 2.3 Mini Access Point Mode

NOTE: For instructions on connecting the USB-Link™ 3 and your PC using Mini Access Point Mode,  
see Connect Using Wi-Fi, in Chapter 3 of this manual.
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Infrastructure Mode (Connecting to your Company’s Network)
In Infrastructure mode, your PC communicates with your company’s computer network through a  
Wireless Access Point (not included), which acts as a bridge between the wireless network and the  
wired network. In this mode, the USB-Link™ 3 is configured to communicate with the same access  
point. All communication between the PC and the USB-Link™ 3 passes through the access point.
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Figure 2.4 Infrastructure Mode

NOTE: The settings for connecting to your company network may differ from one installation to another. 
To ensure network security, your Information Technology (IT) administrator will need to oversee the 
installation and specify the appropriate configuration parameters. Your IT administrator should be able  
to properly configure the USB-Link™ 3 for infrastructure mode, using the USB-Link™ 3 Explorer utility 
(see Switching Modes: Mini Access Point and Infrastructure in Chapter 3 of this manual).
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Chapter 3:
Installing the Drivers and  

Setting Up the Device
Installation Process Outline (pg. 18)

Step 1: Install the Drivers (pg. 19)

Step 2: Connect the USB-Link™ 3 to a Vehicle (pg. 27)

Making a Wired USB Connection (pg. 28)

Making a Wireless Bluetooth Connection (pg. 29)

Pair the Device (pg. 30)

Making a Wireless Wi-Fi Connection (pg. 32)

Mini Access Point Mode (pg. 32)

Infrastructure Mode (pg. 35)

Step 3: Test the Connection (pg. 36)

Using the USB-Link™ 3 Explorer Utility (pg. 40)

The Configuration Tab (pg. 42)

Switching Modes: Mini Access Point and Infrastructure (pg. 43)

The File Menu (pg. 45)

The Tools Menu (pg. 46)

Ping (pg. 46)

Options (pg. 47)

The Help Menu (pg. 49)

This chapter provides instructions for installing USB-Link™ 3 drivers and utilities, connecting the  
USB-Link™ 3 to a vehicle, connecting to a wireless network, testing the connection, and using the 
USB-Link™ 3 Explorer utility.

17

NOTE: Images used throughout this manual are for illustrative purposes only.
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Installation Process Outline
Step 1: Install the USB-Link™ 3 drivers (pg. 19).

Step 2: Connect the USB-Link™ 3 to the vehicle (pg. 27).

 Connect to your PC using one of the following options:

 • A wired, USB connection (pg. 28)

 • A wireless, Bluetooth® connection (pg. 29)

 • A wireless, Wi-Fi connection 

   There are two options:

   - Mini Access Point Mode (pg. 32)

   - Infrastructure Mode (pg. 35)

Step 3: Test the connection between the USB-Link™ 3 and the vehicle using the Device Tester (pg. 36).

18

NOTE: Images used throughout this manual are for illustrative purposes only.
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Step 1: Install the Drivers
Prior to using the USB-Link™ 3, you will need to install the necessary USB-Link™ 3 drivers.  
The USB-Link™ 3 drivers are compatible with Microsoft®, Windows® 10, and Windows® 11.

The following procedure requires that you have Internet access.

To install the drivers on your laptop or PC:

1  On your laptop or PC, navigate to the following website: 
https://www.nexiq.com/Home/Drivers

2 Select the latest version of the USB-Link™ 3 drivers.

3 Click Download.

19

IMPORTANT: Remember, you must have Administrator security rights and be logged in as “Admin”  
to successfully complete the installation process outlined in this manual.

Figure 3.1 NEXIQ Download Page
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4  Click Open to open the downloaded file.

 The Welcome to USB-Link™ 3 Setup screen is displayed.

5 Carefully read the information displayed on the screen and follow the recommendations.

6 Click Next.

20

Figure 3.2 Welcome to USB-Link™ 3 Setup Screen
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The License Agreement screen is displayed.

7 Read all the information on this screen, then click I Agree.

21

Figure 3.3 License Agreement Screen

NOTE: If you do not agree to the terms, click Cancel. A message is displayed prompting you to quit the 
USB-Link™ 3 Setup. Click Yes to quit.
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The following warning message is displayed.

8  Carefully read the warning message. Disconnect all RP1210 adapters connected to your laptop  
or PC prior to proceeding with the installation.

9 Once you have complied with the requirements of the warning message, click OK.

22

Figure 3.4 Warning Message
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When the installation begins, the following screen is displayed.

10 Click Install to continue.

11 Wait briefly while the installation continues.

23

Figure 3.5 Installation Screen
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The Installation Complete screen is displayed.

12 Click Next.

24

Figure 3.6 Installation Complete Screen
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The following completion screen is displayed.

13 Click Finish.

25

Figure 3.7 Completion Screen
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The USB-Link™ 3 Explorer utility opens.

14 Proceed to Step 2: Connect the USB-Link™ 3 to a Vehicle (pg. 27) 

26

Figure 3.8 USB-Link™ 3 Explorer Utility

NOTE: For information on using the USB-Link™ 3 Explorer, see Using the USB-Link™ 3 Explorer Utility  
on page 40 of this manual.
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Step 2: Connect the USB-Link™ 3 to a Vehicle
Once you have installed the USB-Link™ 3 drivers, you are ready to connect the USB-Link™ 3  
to a vehicle using an adapter cable. The following adapters are included in the USB-Link™ 3 kit:

• 9-pin Deutsch Adapter, 1 Meter

• 16-pin, J1962 OBD II Adapter, 1 Meter

Connect the USB-Link™ 3 to your PC using one of the following options:

• A wired, USB connection (pg. 28)

• A wireless, Bluetooth® connection (pg. 29)*

• A wireless Wi-Fi connection (pg. 32)*

  - Mini Access Point Mode (pg. 32)

    or

  - Infrastructure Mode (pg. 35)

*Wireless Edition only
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Making a Wired USB Connection
To connect the USB-Link™ 3 to your PC using a USB cable:

1 Connect the USB cable (i.e., an automotive A to Mini-B USB cable) to the USB port of the PC or laptop.

2 Connect the other end of the cable to the port on the bottom of the USB-Link™ 3.

3 Connect the DB26 female end of the appropriate adapter cable to the USB-Link™ 3.

4 Attach the other end of the adapter cable (i.e., Deutsch connector) to the vehicle’s diagnostic connector.

5 Proceed to Step 3: Test the Connection (pg. 36).

NOTE: The vehicle’s diagnostic connector is typically located under the dashboard on the driver’s side, 
or beside the driver’s seat. It can also be located in the engine compartment near the electronic control 
module (ECM).
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Making a Wireless Bluetooth Connection – Wireless Edition only
When two Bluetooth devices are paired, a persistent link is created between the two devices. After the 
devices are paired, future connections are authenticated automatically.

To connect via Bluetooth:

1 Connect the DB26 female end of the appropriate adapter cable to the USB-Link™ 3.

2 Attach the other end of the adapter cable (i.e., Deutsch connector) to the vehicle’s diagnostic connector.

4 Proceed to Pair the Device (pg. 30)

   - When connected, the Power LED (green) on the USB-Link™ 3 should be illuminated (on).

   - If the Power LED is not illuminated, turn the vehicle’s key to the ON position, leaving the engine off.

3 Press and hold the Pairing Button until the Wireless LED begins to flash blue (about 3 seconds).

This will put the USB-Link™ 3 in Discoverable Mode. When the USB-Link™ 3 is Discoverable,  
a host device can detect, pair, or connect to it. Once a connection with the ECM is established, the  
LED will be solid blue. After two minutes, discoverability will time out, and the device will return to  
Non-Discoverable status.

NOTE: See Device Features in Chapter 2 for a detailed discussion of the Pairing Button.

NOTE: The vehicle’s diagnostic connector is typically located under the dashboard on the driver’s side, 
or beside the driver’s seat. It can also be located in the engine compartment near the electronic control 
module (ECM).
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Pair the Device
Use the Windows® utility to pair the device (i.e., the USB-Link™ 3 with your PC).

To pair the device:

1 Click on the Show Hidden Icons arrow in your PC’s System Tray.

   The hidden icons are displayed.

2 Right-click on the Bluetooth® icon.

3 Click Add a Bluetooth® Device.

   The Add a device screen is displayed.

4  Select the device displayed that matches the serial number on the back of your USB-Link™ 3  
(e.g., USBL3_xxxxxx).

Figure 3.9 Hidden Icons

Figure 3.10 Add a Device Screen
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Pair the Device
5 Click Connect.

6 Click Done.

7 Proceed to Step 3: Test the Connection (pg. 36)
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Making a Wireless Wi-Fi Connection – Wireless Edition only
When using Wi-Fi, the USB-Link™ 3 can be configured for either of the following modes:

• Mini Access Point, the Wi-Fi default (pg. 32)

• Infrastructure (pg. 35)

Mini Access Point Mode
The easiest and quickest way to connect your USB-Link™ 3 to your PC is with the Mini Access Point 
mode. In Mini Access Point mode (also known as Access Point Emulation mode), the PC communicates 
directly with the USB-Link™ 3. The USB-Link™ 3 emulates the function of an access point, allowing 
the PC to connect directly to the USB-Link™ 3. When the PC is connected to the USB-Link™ 3 in Mini 
Access Point mode, neither device is connected to the company network.

NOTE: USB-Link™ 3 cannot be used in Infrastructure mode until it has been configured using the 
Explorer utility (see Using the USB-Link™ 3 Explorer Utility on page 40 of this chapter).

Figure 3.11 Mini Access Point Mode
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To connect the USB-Link™ 3 to your PC using Mini Access Point Mode:

1  Connect the DB26 female end of the appropriate adapter cable to the connector on the top of  
the USB-Link™ 3.

2 Attach the other end of the adapter cable (i.e., Deutsch connector) to the vehicle’s diagnostic connector.

   - When connected, the Power LED (green) on the USB-Link™ 3 should be illuminated (On).

   - If the Power LED is not illuminated, turn the vehicle’s key to the ON position, leaving the engine Off.

3 Navigate to the System Tray on your PC.

4 Click on the Network icon in the System Tray.

NOTE: The vehicle’s diagnostic connector is typically located under the dashboard on the driver’s side, 
or beside the driver’s seat. It can also be located in the engine compartment near the electronic control 
module (ECM).

Figure 3.12 Windows® System Tray
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The Network Selection screen is displayed.

6 Click Connect.

   The device is now connected and ready to use.

7 Proceed to Step 3: Test the Connection (pg. 36)

5 Select USBL3_xxxxxx from the list (xxxxxx represents the serial number of the USB-Link™ 3).

NOTE: If USBL3_xxxxxx is not displayed, make sure you are connected to the vehicle and are within 
range (i.e., within 50 ft.). You may need to move your PC closer to the vehicle.

Figure 3.13 Network Selection Screen
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Infrastructure Mode
In Infrastructure mode, your PC communicates with your company’s computer network through a  
Wireless Access Point (not included), which acts as a bridge between the wireless network and the  
wired network. In this mode, the USB-Link™ 3 is configured to communicate with the same access  
point. All communication between the PC and the USB-Link™ 3 passes through the access point.

Figure 3.14 Infrastructure Mode

NOTE: The settings for connecting to your company network may differ from one installation to another. 
To ensure network security, your Information Technology (IT) administrator will need to oversee the 
installation and specify the appropriate configuration parameters. Your IT administrator should be able  
to properly configure the USB-Link™ 3 for infrastructure mode, using the USB-Link™ 3 Explorer utility 
(see Switching Modes: Mini Access Point and Infrastructure on page 43).
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Step 3: Test the Connection
Use the Device Tester to test the connection between the USB-Link™ 3 and the vehicle. At startup,  
the Device Tester checks for any USB-Link™ 3 drivers installed on the PC.

To test the connection between the USB-Link™ 3 and the vehicle:

1 Click Start and then select All Programs > NEXIQ > Device Tester.

   The application is started and the Device Tester screen is displayed.

2  Use the button in the Driver box to select the appropriate driver (i.e., USB-Link™ 3).

3  Use the button in the Device box to select the appropriate device (for example, USB-Link™ 3, Bluetooth®).

   - The Device box lists all the devices supported by the USB-Link™ 3 drivers installed on the PC.

Figure 3.15 Device Tester: Status Not Connected
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4  Use the button in the Protocol box to select the appropriate protocol (e.g., J1939, CAN,  
ISO 15365, J1708).

   - The Protocol box lists only the protocols supported by the device selected in the Device box.

5 Press the Start Test button.

    The Device Test screen is refreshed and the Connection Indicator button (located in the bottom  
left corner of the display) changes from Not Connected (red) to Connected (green).

The Vehicle Info window displays information about the vehicle to which you are connected  
(depending on the protocol selected).

The Modules Detected window in the middle of the screen displays a list of all systems seen on  
the bus. It is used for J1308 and J1939 only. For all other protocols this window will be unavailable  
(i.e., NOT USED).

The Bus Messages window at the bottom of the screen displays data received from the vehicle bus.

Figure 3.16 Communication Validation Tool: Status Connected
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If the Connection Indicator button is red (i.e., Not Connected), do one of the following:

For a wireless connection:

• In the Device list, make sure that the appropriate device is selected, for example:

   - USB-Link3, Bluetooth or

   - USB-Link3, WiFi

•  In the Protocol list, make sure that the appropriate protocol is selected, for example SAE  
J1939 Protocol.

•  Check to ensure that the connections between the USB-Link™ 3 and the vehicle are secure  
(i.e., the Diagnostic Connector).

• Check to make certain that the Power LED on the USB-Link™ 3 is illuminated.

For a wired connection using a USB cable:

• In the Device list, make sure that the appropriate device is selected, for example USB-Link3, USB.

• In the Protocol list, make sure the appropriate protocol is selected, for example SAE J1939 Protocol.

•  Check to ensure that the connections between the USB-Link™ 3 and the PC are secure  
(i.e., the USB cable).

• Check the connections between the USB-Link™ 3 and the vehicle (i.e., the Diagnostic Connector).

• Check to make certain that the Power LED on the USB-Link™ 3 is illuminated.

6 Click on the Component Info button.

NOTE: For additional information, refer to Step 2: Connect the USB-Link™ 3 to a Vehicle (pg. 27)
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The Component Information window is displayed.

7  When you are finished viewing the information, click the Close button in the upper right corner of  
the window.

8 Click Stop Test to end the test, or select another device to test.

NOTE: Component Information for Engines and Brakes is available only during a J1708 connection.

Figure 3.17 Component Information Window
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Using the USB-Link™ 3 Explorer Utility
The USB-Link™ 3 Explorer utility opened automatically when you installed the USB-Link™ 3 drivers  
and utilities (see Figure 3.8, on page 26).

To re-open the USB-Link™ 3 Explorer once it has been closed, click on the Show Hidden Icons arrow  
in your PC’s System Tray.

Double-click on the USB-Link™ 3 icon 3.

NOTE: You can also access the USB-Link™ 3 Explorer from your PC’s Start menu. Click Start and then 
select All Programs > NEXIQ > USB-LinkTM 3 Explorer.

Figure 3.18 Hidden Icons
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The USB-Link™ 3 Explorer opens.

The following menu options are provided:

• File (pg. 45)

• Tools (pg. 46)

• Help (pg. 49)

Each menu option includes a number of features. Menu options are discussed in the  
following sub-sections.

When you click on a USB-Link™ 3 in the list, the Configuration tab is displayed (Figure 3.20).

Figure 3.19 USB-Link™ 3 Explorer
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The Configuration Tab
The Configuration tab provides the following information:

• Device

  - Name

  - MAC Address

• Wireless Settings

• Internet Protocol (TCP/IP) Settings

This information can be useful when troubleshooting network connection problems. Use the Configuration 
tab when switching between Mini Access Point and Infrastructure.

To access the Configuration tab:

1 Click on a USBL3_xxxxxx in the list in the left pane of the Explorer.

Figure 3.20 Configuration Tab
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Switching Modes: Mini Access Point and Infrastructure
From the USB-Link™ 3 Explorer Configuration tab, use the Mode drop-down menu under Wireless 
Settings to switch between Mini Access Point and Infrastructure modes.

Once you have selected Infrastructure from the drop-down menu, additional fields in the Wireless 
Settings portion of the screen are available.

Figure 3.21 Wireless Settings: Mode Drop-down Menu

NOTE: For a graphic depiction of a typical Infrastructure Mode setup, see Figure 3.14 (pg. 35)
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The following Wireless Settings fields are available:

• Network Name

• Security (WPA/WPA2)

• Password

The Internet Protocol (TCP/IP) portion of the screen is also available to enter the required settings. 
There are two options:

• Obtain an IP address automatically (i.e., a dynamic IP address)

• Specify an IP address (i.e., a static IP address that does not change)

   - IP Address

   - Subnet Mask

   - Default Gateway

NOTE: You will need to obtain this information (i.e., IP Address, Subnet Mask) from the designated IT 
person or network administrator for your location. Depending on how your local network is configured, 
you may also need to enter Default Gateway information.

NOTE: The settings for connecting to your company network may differ from one installation to another. 
To ensure network security, your Information Technology (IT) administrator will need to oversee the 
installation and specify the appropriate configuration parameters.
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The File Menu
The File menu has one feature, Exit. Use the Exit feature to close the USB-Link™ 3 Explorer.

To exit the USB-Link™ 3 Explorer:

1 Select File from the USB-Link™ 3 Explorer menu bar.

2 Select Exit.

   The USB-Link™ 3 Explorer closes.

Figure 3.22 Exit Selected
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The Tools Menu
The Tools menu provides the following features:

• Ping

• Options

Ping
The Ping feature uses the PING command to check for the presence of a device on the network.

To check for a device:

1 Select Tools from the USB-Link™ 3 Explorer menu bar.

2 Select Ping.

3 Enter the IP address of the device you want to locate (e.g., 192.168.123.103).

4 Click Start.

   The USB-Link™ 3 Explorer searches for the device and, if found, displays the reply.

5 Click Stop.

6 Click the Close button on the dialog box.

Figure 3.23 Ping Dialog Box
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Options
The Options feature provides the following features which are presented as check boxes:

• Start USB-Link™ 3 Explorer when Windows starts (pg. 47)

• Show New USB-Link™ 3 Notification (pg. 48)

Start USB-Link™ 3 Explorer when Windows Starts
Use this feature to set when the USB-Link™ 3 Explorer opens. The default setting opens  
the USB-Link™ 3 Explorer when Windows starts.

To change the default, click on the check box to remove the check mark. 

Click OK.

Figure 3.24 Options Menu
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Show New USB-Link™ 3 Notification
Use this feature to set when the New USB-LinkTM 3 notification message box displays.

To change the default, click the box to remove the check mark. Then click OK.

The default is set to display the notification message box whenever a new USB-Link™ 3 is detected.

Figure 3.25 Notification Box

Figure 3.26 Options Menu
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The Help Menu
The Help menu has one feature, About. Use the About feature to display information about the  
USB-Link™ 3 Explorer.

To access the Help menu:

1 Select Help from the USB-Link™ 3 Explorer menu bar.

2 Select About.

3 When you are finished reviewing the information, click OK to close the dialog box.

Figure 3.27 About USB-Link™ 3 Explorer
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